viernes, 18 de julio de 2014

Problemas con WSJT-X v1.3

Durante bastante tiempo estuve utilizando el programa de Joe Taylor - K1JT, WSJT-X v1.2 para los modos JT65 y JT9, pero a partir de las primeras versiones 1.3, me encontré con serios problemas en el programa, pues era incapaz de descodificar una trama. Curiosamente al volver a la versión 1.2 todo volvía a la normalidad.

La ventana de la cascada gráfica mostraba la entrada de señal y los ajustes de configuración eran idénticos en ambas versiones, pero mientras que la cascada se veía límpia en v1.2...

WSJT-X v1.2
...Por el contrario, en las versiones 1.3 daba la sensación de saturación y presencia de ecos en la imagen. Puede verse con claridad la diferencia de trabajo de ambas versiones corriendo a la vez en la misma frecuencia y mismo PC.

WSJT-X v1.3
Parece ser que los controladores de algunas tarjetas de sonido son incompatibles con la versión 1.3, por lo que Joe Taylor - K1JT ha facilitado una solución a este problema, que pasa por editar el archivo de configuración WSJT-X.INI y añadir al final del mismo las siguientes líneas:
  • [Tune]
  • Audio\DisableInputResampling=true
En mi caso, después de agregar esta solución en el archivo de configuración, la versión 1.3 de WSJT-X empezó a funcionar de maravilla tanto en modo JT65 como en JT9.

4 comentarios:

ROBERTO dijo...

GRACIAS JAVIER POR TUS COMENTARIOS SOBRE JT9, MUY UTILES
73 DX
ROBERTO LW2ESG

Juan Jose Diaz dijo...

Javier ,yo tengo la version 1.6 y me pasa lo mismo ,no decodifica en algunos casos y no encuentro el archivo wsjt-x.ini???

Javier Bermejo dijo...

Hola Juan José Diaz.
Yo creo que tu problema con la versión 1.6 no tiene nada que ver con lo que ocurría hace tiempo en la versión 1.3

Aquel fallo junto con la solución que comenté en este hilo, está superado y yo personalmente no he vuelto a ver el problema, que se debía a las características de mi tarjeta de sonido.

El archivo wsjt-x.ini no deberías tocarlo para meter el parámetro comentado en la solución para v1.3, pues no te ayudaría en nada.

Además dices que a tí no te descodifica en algunos casos, no sé cuales son los casos en los que falla y en los que no, pero si el problema ocurre algunas veces, eso es lo que tendrás que investigar.

Sólo una recomendación de mi parte, no subas demasiado la entrada de señal de micro, pues pudieras estar saturando y eso puede ser una d las causas.

Suerte. 73

Javier Bermejo dijo...

Juan José Diaz.
Damos por garantizado que el reloj de tu PC está perfectamente sincronizado con los patrones horarios? No vaya a ser que tengas un desfase de unos segundos y sea esa la razón!!!